Cấu hình Router Mikrotik bằng Script

Cấu hình router mikrotik bằng Script thật đơn giản cho gười không chuyên

I.Giới thiệu

  • Có nhiều cách đề cấu hình Router Mikrotik như thông qua giao diện đồ họa và cấu hình thông qua CLI (comment line).
  • Mỗi cách cấu hình thì có ưu và nhược điểm khác nhau. Đối với cách cấu hình thông qua đồ họa thì các bạn phải thao tác nhiều và thật sự am hiểu các tùy chọn cũng như các bước cấu hình. Còn với cách cấu hình thông qua CLI thì các bạn phải có ít kiến thức lập trình và nhớ lệnh. Tuy nhiên hôm nay Hoàng Lâm sẽ bày cho các bạn cách cấu hình thông qua CLI mà không cần phải biết nhiều thứ, chỉ cần coppy paste là đủ nhé !

II.Cấu hình Router Mikrotik bằng Script cơ bản

  • Nội dung: cấu hình Router mikrotik quay PPP0e với Vlan Tag 35 của nhà mạng trên cổng eth1; Bridge các port 2,3,4,5 lại với nhau và cấu hình Network là 192.168.1.1/24; cấu hình NAT để client truy cập internet … 

1.Reset router

  • Lưu ý, trước khi cấu hình thiết bị, các bạn nên reset thiết bị về cấu hình mặc định của NSX để tránh các lỗi trong quá trình thực hiện.

2.Đăng nhập vào router mikrotik

  • Dùng winbox đăng nhập vào thiết bị, chọn New terminal để bắt đầu cấu hình.

3.Tạo vlan cho cổng PPP0E

  • Tùy thuộc vào nhà mạng sẽ có vlan khác nhau, vd mình dùng nhà mạng viettel sẽ khai báo vlan 35

/interface vlan

add interface=ether1 name=vlan35 vlan-id=35

4.Quay ppp0e trên vlan vừa tạo

  • Tại mục passISP và userISP, các bạn điền đúng thông tin vào nhé

/interface pppoe-client

add add-default-route=yes disabled=no interface=vlan35 name=pppoe-out1 \

    password=passISP user=userISP

5.Cấu hình DNS để phân giải tên miền

/ip dns

set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

6.Cấu hình Bridge LAN

/interface bridge

add add-dhcp-option82=yes dhcp-snooping=yes name=bridgeLAN

7.Đưa các port vào Bridge vừa tạo

/interface bridge port

add bridge=bridgeLAN interface=ether2

add bridge=bridgeLAN interface=ether3

add bridge=bridgeLAN interface=ether4

add bridge=bridgeLAN interface=ether5

8.Đặt ip cho Bridge vừa tạo

/ip address

add address=192.168.1.1/24 interface=bridgeLAN network=192.168.1.0

9.Cấu hình IP Pool

  • Tại đây, mình set dãy ip sẽ cấp cho client và đặt tên cho Pool

/ip pool

add name="dhcp_pool LAN" ranges=192.168.1.10-192.168.1.254

10.Cấu hình DHCP trong dịch vụ DHCP Server

/ip dhcp-server

add address-pool="dhcp_pool LAN" disabled=no interface=bridgeLAN lease-time=\

    8h name=dhcp1

11.Cấu hình Networks trong dịch vụ DHCP server

/ip dhcp-server network

add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1

12.Thực hiện NAT để client truy cập internet

/ip firewall nat

add action=masquerade chain=srcnat comment="nat local ra internet" \

    out-interface=pppoe-out1

13.Set thời gian và đặt tên cho router

/system clock

set time-zone-name=Asia/Ho_Chi_Minh

/system identity

set name=mikdemo

14.Tắt các dịch vụ không cần thiết để tránh bị tấn công

/ip service

set telnet disabled=yes

set ftp disabled=yes

set ssh disabled=yes

set www-ssl tls-version=only-1.2

set api disabled=yes

set api-ssl disabled=yes

 

15.Kiểm tra

  • Sau khi cấu hình xong, client đã truy cập internet thành công

III. Kết luận về cấu hình Router Mikrotik bằng Script

  • Như vậy, Hoàng Lâm vừa hướng dẫn xong cho các bạn cách cấu hình cơ bản Router Mikrotik thông qua CLI
  • Các bạn có nhu cầu Download  tài liệu PDF về “Cấu hình Router Mikrotik bằng Script “, hãy liên hệ với chúng tôi: TẠI ĐÂY
  • các bạn tham khảo lại các bài viết về Mikrotik : TẠI ĐÂY
  • Trong quá trình sử dụng hoặc thao tác nếu có lỗi phát sinh thì các bạn hãy liên hệ với chúng tôi để được hỗ trợ qua: https://www.facebook.com/congnghewifi.vn
  • Hãy tham gia Group FaceBook: Cộng Đồng Network-CCTV-Wifi để cùng trao đổi kinh nghiệm và mua bán các sản phẩm liên quan.
  • Nếu bài viết hay và có sức ảnh hưởng, các bạn vui lòng cho Hoàng Lâm xin đánh giá và comment để tạo động lực cho Hoàng Lâm làm thêm các tài liệu, cảm ơn tất cả mọi người !
Bình Luận Bài Viết
3.2/5 - (4 bình chọn)

THÔNG TIN LIÊN HỆ

CÔNG TY TNHH CÔNG NGHỆ HOÀNG LÂM

error: Alert: Bản quyền thuộc về Cty TNHH Công Nghệ Hoàng Lâm